New versions of egeoffrey-controller and egeoffrey-gui



  • As soon as on a page the widget is saved, the page is closed. It is not possible to save the page. That ends up with the widget not being available.

    Strange, I did not change anything in that workflow during the last weeks. I will try to reproduce it. What do you mean by is closed? You mean shows up like before the change? Also anything in the logs?



  • @user2684
    When I save the widget the buttons to save definitively are going away before I have the chance to click on the save button. In the log is nothing. No configuration saved line.



  • @user2684
    I tried whatever I could think of. Cleaned history, other machine. Once I succeeded by clicking very fast. But there after the page did not show the widget. Renewed the page. Nothing.

    No clue what is going on.



  • @eporocrail unfortunately despite many attempts I could't reproduce it. So you click on "Edit Page", then to "Add widget", fill in the information, you click on "Save" (and the new widget should show up), then click on "Save Changes" and after a few seconds the widget should show up.

    Is it the "Save" button or the "Save Changes" which is disappearing? Using Chrome?



  • @user2684
    After I click the "Save" button the widget does NOT appear.

    I tried with safari and Firefox. Let's try Chrome also.



  • @user2684
    Chrome same story.

    I assume there is only one thing left. Complete fresh install including Raspi OS.

    I will let you know what the result is.



  • @eporocrail mmm weird gui behaviour cannot be solved by a fresh install IMHO. If when clicking on "Save" the new widget does not show up it is completely client side (all javascript making up the preview), the backend is not even called. Anything showing up when you click on "Save" in the browser console logs? I assume you also already tried with different widget types and settings



  • @user2684

    I suppose I have some OFF days.

    If you insert the topic instead of the sensor name than things are getting mixed up.

    Sorry for bothering you with this.

    To be clear: it is working OK.



  • @eporocrail as far as it is working, I'm happy with it 🙂 For sure there are still plenty of sanity checks the gui is not going and could do like e.g. presenting a dropdown with all the available sensors.



  • @user2684
    It is a tough job to prevent the user from making all possible mistakes.

    But I get to like your system more and more as I get to know it better. You do a formidable job creating eGeoffrey.


Log in to reply